Whamcloud - gitweb
LU-4629 lov: fix sscanf format specification
[fs/lustre-release.git] / libsysio / Makefile.am
index 11e6e3d..1262105 100644 (file)
@@ -48,16 +48,14 @@ OPTIONAL_YOD_SRCS =
 endif
 
 if WITH_LUSTRE_HACK
-OPTIONAL_LUSTRE_SRCDIR_SRCS = $(LUSTRE_SRCDIR_SRCS)
 # it would be better that let configure script check this
-AM_CFLAGS = -fPIC
-else
-OPTIONAL_LUSTRE_SRCDIR_SRCS = 
+OPTIONAL_LUSTRE_CFLAGS = -fPIC
 endif
 
+AM_CFLAGS = $(OPTIONAL_LUSTRE_CFLAGS)
+
 __LIBBUILD_DIR__libsysio_a_SOURCES = \
        $(SRCDIR_SRCS) \
-       $(OPTIONAL_LUSTRE_SRCDIR_SRCS) \
        $(OPTIONAL_STDFD_SRCS) \
        $(OPTIONAL_INCORE_SRCS) \
        $(OPTIONAL_SOCKETS_SRCS) \
@@ -84,8 +82,8 @@ really-clean: testsclean maintainer-clean
        cd $(TESTDIR); rm -rf Makefile Makefile.in .deps
 
 tests: $(lib_LIBRARIES) FORCE
-       cd $(TESTDIR); make
+       cd $(TESTDIR); ${MAKE}
 testsclean: FORCE
-       cd $(TESTDIR); make clean
+       cd $(TESTDIR); ${MAKE} clean
 clean: testsclean clean-am
 FORCE: