Whamcloud - gitweb
LU-1201 checksum: add libcfs crypto hash
[fs/lustre-release.git] / libcfs / include / libcfs / Makefile.am
index 733fe3e..89054ee 100644 (file)
@@ -1,9 +1,14 @@
-SUBDIRS := linux
+SUBDIRS := linux posix util
 if DARWIN
 SUBDIRS += darwin
 endif
-DIST_SUBDIRS := $(SUBDIRS)
+DIST_SUBDIRS := linux posix util darwin
 
 EXTRA_DIST := curproc.h libcfs_private.h libcfs.h list.h lltrace.h \
-       portals_utils.h types.h user-lock.h user-prim.h user-time.h \
-       user-tcpip.h user-bitops.h bitmap.h
+               user-lock.h user-prim.h user-time.h user-mem.h \
+               user-tcpip.h user-bitops.h bitmap.h \
+               libcfs_prim.h libcfs_time.h libcfs_hash.h libcfs_cpu.h \
+               libcfs_debug.h libcfsutil.h libcfs_ioctl.h \
+               libcfs_pack.h libcfs_unpack.h libcfs_string.h \
+               libcfs_kernelcomm.h libcfs_workitem.h lucache.h \
+               libcfs_fail.h params_tree.h libcfs_crypto.h