Whamcloud - gitweb
LU-11825 llite: Remove ptask framework
[fs/lustre-release.git] / libcfs / include / libcfs / Makefile.am
index b8e5907..7164dbb 100644 (file)
@@ -1,13 +1,19 @@
-SUBDIRS := linux posix util
-if DARWIN
-SUBDIRS += darwin
-endif
-DIST_SUBDIRS := $(SUBDIRS)
+SUBDIRS = linux util
+DIST_SUBDIRS = linux util
 
-EXTRA_DIST := curproc.h libcfs_private.h libcfs.h list.h lltrace.h \
-               user-lock.h user-prim.h user-time.h user-mem.h \
-               user-tcpip.h user-bitops.h bitmap.h \
-               libcfs_prim.h libcfs_time.h libcfs_hash.h \
-               libcfs_debug.h libcfsutil.h libcfs_ioctl.h \
-               libcfs_pack.h libcfs_unpack.h libcfs_string.h \
-               libcfs_kernelcomm.h
+libcfsdir = $(includedir)/libcfs
+
+EXTRA_DIST = \
+       bitmap.h \
+       curproc.h \
+       libcfs.h \
+       libcfs_cpu.h \
+       libcfs_crypto.h \
+       libcfs_debug.h \
+       libcfs_fail.h \
+       libcfs_hash.h \
+       libcfs_heap.h \
+       libcfs_prim.h \
+       libcfs_private.h \
+       libcfs_string.h \
+       libcfs_workitem.h