Whamcloud - gitweb
LU-11825 llite: Remove ptask framework
[fs/lustre-release.git] / libcfs / include / libcfs / Makefile.am
index 472d0ae..7164dbb 100644 (file)
@@ -1,9 +1,19 @@
-SUBDIRS := linux
-if DARWIN
-SUBDIRS += darwin
-endif
-DIST_SUBDIRS := $(SUBDIRS)
+SUBDIRS = linux util
+DIST_SUBDIRS = linux util
 
-EXTRA_DIST := curproc.h kp30.h libcfs.h list.h lltrace.h \
-       portals_utils.h types.h user-lock.h user-prim.h user-time.h \
-       user-tcpip.h user-bitops.h bitmap.h
+libcfsdir = $(includedir)/libcfs
+
+EXTRA_DIST = \
+       bitmap.h \
+       curproc.h \
+       libcfs.h \
+       libcfs_cpu.h \
+       libcfs_crypto.h \
+       libcfs_debug.h \
+       libcfs_fail.h \
+       libcfs_hash.h \
+       libcfs_heap.h \
+       libcfs_prim.h \
+       libcfs_private.h \
+       libcfs_string.h \
+       libcfs_workitem.h