Whamcloud - gitweb
LU-2675 build: remove Darwin "support"
[fs/lustre-release.git] / libcfs / include / libcfs / Makefile.am
index d074151..2244baa 100644 (file)
@@ -1,13 +1,39 @@
-SUBDIRS := linux posix util
-if DARWIN
-SUBDIRS += darwin
+SUBDIRS = linux posix util
+DIST_SUBDIRS = linux posix util
+
+libcfsdir = $(includedir)/libcfs
+
+if UTILS
+libcfs_HEADERS = types.h
 endif
-DIST_SUBDIRS := linux posix util darwin
 
-EXTRA_DIST := curproc.h libcfs_private.h libcfs.h list.h lltrace.h \
-               user-lock.h user-prim.h user-time.h user-mem.h \
-               user-tcpip.h user-bitops.h bitmap.h \
-               libcfs_prim.h libcfs_time.h libcfs_hash.h \
-               libcfs_debug.h libcfsutil.h libcfs_ioctl.h \
-               libcfs_pack.h libcfs_unpack.h libcfs_string.h \
-               libcfs_kernelcomm.h libcfs_workitem.h
+EXTRA_DIST = \
+       bitmap.h \
+       curproc.h \
+       err.h \
+       libcfs.h \
+       libcfs_cpu.h \
+       libcfs_crypto.h \
+       libcfs_debug.h \
+       libcfs_fail.h \
+       libcfs_hash.h \
+       libcfs_heap.h \
+       libcfs_ioctl.h \
+       libcfs_kernelcomm.h \
+       libcfs_prim.h \
+       libcfs_private.h \
+       libcfs_string.h \
+       libcfs_time.h \
+       libcfs_workitem.h \
+       libcfsutil.h \
+       list.h \
+       lucache.h \
+       params_tree.h \
+       types.h \
+       user-bitops.h \
+       user-crypto.h \
+       user-lock.h \
+       user-mem.h \
+       user-prim.h \
+       user-tcpip.h \
+       user-time.h