Whamcloud - gitweb
LU-2675 build: remove Darwin "support"
[fs/lustre-release.git] / libcfs / include / libcfs / Makefile.am
index cb5ccb2..2244baa 100644 (file)
@@ -1,8 +1,11 @@
 SUBDIRS = linux posix util
-if DARWIN
-SUBDIRS += darwin
+DIST_SUBDIRS = linux posix util
+
+libcfsdir = $(includedir)/libcfs
+
+if UTILS
+libcfs_HEADERS = types.h
 endif
-DIST_SUBDIRS = linux posix util darwin
 
 EXTRA_DIST = \
        bitmap.h \
@@ -17,17 +20,16 @@ EXTRA_DIST = \
        libcfs_heap.h \
        libcfs_ioctl.h \
        libcfs_kernelcomm.h \
-       libcfs_pack.h \
        libcfs_prim.h \
        libcfs_private.h \
        libcfs_string.h \
        libcfs_time.h \
-       libcfs_unpack.h \
        libcfs_workitem.h \
        libcfsutil.h \
        list.h \
        lucache.h \
        params_tree.h \
+       types.h \
        user-bitops.h \
        user-crypto.h \
        user-lock.h \