Whamcloud - gitweb
b=23368 MMP: Watchdog detected LOCKUP on CPU 1 RIP: __list_add+0x6/0x68
[fs/lustre-release.git] / ldiskfs / configure.ac
index 7de84cf..e20d087 100644 (file)
@@ -1,6 +1,6 @@
 # Process this file with autoconf to produce a configure script.
 
-AC_INIT([Lustre ldiskfs], 3.0.8, [https://bugzilla.lustre.org/])
+AC_INIT([Lustre ldiskfs], 3.3.0, [https://bugzilla.lustre.org/])
 AC_CONFIG_SRCDIR([lustre-ldiskfs.spec.in])
 
 # Don't look for install-sh, etc. in ..
@@ -33,13 +33,6 @@ $2
 esac
 ])
 
-AC_DEFUN([LC_KERNEL_WITH_EXT4],
-[if test -f $LINUX/fs/ext4/ext4.h ; then
-$1
-else
-$2
-fi
-])
 
 AC_MSG_CHECKING([whether to build kernel modules])
 AC_ARG_ENABLE([modules],
@@ -90,19 +83,15 @@ AM_CONDITIONAL(USE_QUILT, test x$QUILT != xno)
 
 LB_DEFINE_LDISKFS_OPTIONS
 
-AC_MSG_CHECKING([whether to build ldisk base on ext4])
-AC_ARG_ENABLE([ext4],
-             AC_HELP_STRING([--disable-ext4],
-                            [disable building of ldiskfs base on ext4]),[],
-                            [LC_KERNEL_WITH_EXT4([enable_ext4='yes'],
-                            [enable_ext4='no'])])
-AC_MSG_RESULT([$enable_ext4])
+LB_HAVE_EXT4_ENABLED
 
 if test x$enable_ext4 = xyes ; then
-        BACKFS=ext4
+       AC_DEFINE(HAVE_EXT4_LDISKFS, 1, [ldiskfs based on ext4])
+       BACKFS=ext4
 else
-        BACKFS=ext3
+       BACKFS=ext3
 fi
+
 AC_SUBST(BACKFS)
 BACKFSU=${BACKFS/ext/EXT}
 AC_SUBST(BACKFSU) # We need a Upper string
@@ -130,7 +119,7 @@ case $LINUXRELEASE in
        fi
        ;;
 2.6.22*) LDISKFS_SERIES="2.6.22-vanilla.series";;
-2.6.27*) LDISKFS_SERIES="2.6.27-vanilla.series";;
+2.6.27*) LDISKFS_SERIES="2.6-sles11.series";;
 *) AC_MSG_WARN([Unknown kernel version $LINUXRELEASE, fix ldiskfs/configure.ac])
 esac
 AC_MSG_RESULT([$LDISKFS_SERIES])