Whamcloud - gitweb
Branch b1_6
[fs/lustre-release.git] / ldiskfs / configure.ac
index 6ccf1c8..c63a847 100644 (file)
@@ -3,6 +3,9 @@
 AC_INIT([Lustre ldiskfs], 3.0.0, [https://bugzilla.lustre.org/])
 AC_CONFIG_SRCDIR([lustre-ldiskfs.spec.in])
 
+# Don't look for install-sh, etc. in ..
+AC_CONFIG_AUX_DIR([.])
+
 AC_CANONICAL_SYSTEM
 
 AM_INIT_AUTOMAKE
@@ -12,7 +15,20 @@ AC_PROG_CC
 LB_CANONICAL_SYSTEM
 LB_INCLUDE_RULES
 LB_PROG_CC
-LB_PROG_LINUX
+
+AC_MSG_CHECKING([whether to build kernel modules])
+AC_ARG_ENABLE([modules],
+       AC_HELP_STRING([--disable-modules],
+                       [disable building of Lustre kernel modules]),
+       [],[
+               enable_modules='yes'
+       ])
+AC_MSG_RESULT([$enable_modules])
+
+if test x$enable_modules = xyes ; then
+       LB_PROG_LINUX
+fi
+
 LB_CONFIG_HEADERS
 
 # These allow Lustre Makefiles and autoMakefiles to be used unchanged.