Whamcloud - gitweb
Branch HEAD
[fs/lustre-release.git] / ldiskfs / configure.ac
index 7ae8f16..a673712 100644 (file)
@@ -1,6 +1,6 @@
 # Process this file with autoconf to produce a configure script.
 
-AC_INIT([Lustre ldiskfs], 3.0.0, [https://bugzilla.lustre.org/])
+AC_INIT([Lustre ldiskfs], 3.0.6, [https://bugzilla.lustre.org/])
 AC_CONFIG_SRCDIR([lustre-ldiskfs.spec.in])
 
 # Don't look for install-sh, etc. in ..
@@ -15,7 +15,40 @@ AC_PROG_CC
 LB_CANONICAL_SYSTEM
 LB_INCLUDE_RULES
 LB_PROG_CC
-LB_PROG_LINUX
+
+
+#
+# LC_TARGET_SUPPORTED
+#
+# is the target os supported?
+#
+AC_DEFUN([LC_TARGET_SUPPORTED],
+[case $target_os in
+       linux* | darwin*)
+$1
+               ;;
+       *)
+$2
+               ;;
+esac
+])
+
+
+AC_MSG_CHECKING([whether to build kernel modules])
+AC_ARG_ENABLE([modules],
+             AC_HELP_STRING([--disable-modules],
+                            [disable building of Lustre kernel modules]),[],
+                            [LC_TARGET_SUPPORTED([enable_modules='yes'],
+                            [enable_modules='no'])])
+AC_MSG_RESULT([$enable_modules])
+
+if test x$enable_modules = xyes ; then
+       LB_PROG_LINUX
+if test x$linux25 = xyes ; then
+       LB_LINUX_MODPOST
+fi
+fi
+
 LB_CONFIG_HEADERS
 
 # These allow Lustre Makefiles and autoMakefiles to be used unchanged.
@@ -29,8 +62,9 @@ AC_SUBST(LDISKFSDIR)
 
 AC_MSG_CHECKING([whether to enable quilt for making ldiskfs])
 AC_ARG_ENABLE([quilt],
-               AC_HELP_STRING([--disable-quilt],[disable use of quilt for ldiskfs]),
-               [],[enable_quilt='yes'])
+             AC_HELP_STRING([--disable-quilt],
+                            [disable use of quilt for ldiskfs]),[],
+                            [enable_quilt='yes'])
 AC_MSG_RESULT([$enable_quilt])
 
 AC_PATH_PROG(PATCH, patch, [no])
@@ -58,7 +92,14 @@ case $LINUXRELEASE in
 2.6.12*) LDISKFS_SERIES="2.6.12-vanilla.series" ;;
 2.6.15*) LDISKFS_SERIES="2.6-fc5.series";;
 2.6.16*) LDISKFS_SERIES="2.6-sles10.series";;
-2.6.18*) LDISKFS_SERIES="2.6.18-vanilla.series";;
+2.6.18*)
+       if test x$RHEL_KENEL = xyes; then
+               LDISKFS_SERIES="2.6-rhel5.series"
+       else
+               LDISKFS_SERIES="2.6.18-vanilla.series"
+       fi
+       ;;
+2.6.22*) LDISKFS_SERIES="2.6.22-vanilla.series";;
 *) AC_MSG_WARN([Unknown kernel version $LINUXRELEASE, fix ldiskfs/configure.ac])
 esac
 AC_MSG_RESULT([$LDISKFS_SERIES])
@@ -66,10 +107,34 @@ AC_SUBST(LDISKFS_SERIES)
 
 AC_SUBST(ac_configure_args)
 
+LB_CHECK_SYMBOL_EXPORT([d_rehash_cond],
+                      [fs/dcache.c],
+                      [AC_DEFINE(HAVE_D_REHASH_COND, 1,
+                                 [d_rehash_cond is exported by the kernel])],
+                                 [])
+
+LB_CHECK_SYMBOL_EXPORT([__d_rehash],
+                      [fs/dcache.c],
+                      [AC_DEFINE(HAVE___D_REHASH, 1,
+                                 [__d_rehash is exported by the kernel])],
+                                 [])
+
+LB_CHECK_SYMBOL_EXPORT([d_move_locked],
+                      [fs/dcache.c],
+                      [AC_DEFINE(HAVE_D_MOVE_LOCKED, 1,
+                                 [d_move_locked is exported by the kernel])],
+                                 [])
+
+LB_CHECK_SYMBOL_EXPORT([__d_move],
+                      [fs/dcache.c],
+                      [AC_DEFINE(HAVE___D_MOVE, 1,
+                                 [__d_move exported by the kernel])],
+                                 [])
+
 LB_CONFIG_FILES
 AC_CONFIG_FILES([ldiskfs/autoMakefile ldiskfs/Makefile])
 
-MOSTLYCLEANFILES='.*.cmd .*.flags *.o *.ko *.mod.c .depend .*.1.*'
+MOSTLYCLEANFILES='.*.cmd .*.flags *.o *.ko *.mod.c .depend .*.1.* Modules.symvers Module.symvers'
 AC_SUBST(MOSTLYCLEANFILES)
 
 AC_OUTPUT