Whamcloud - gitweb
Branch b1_6
[fs/lustre-release.git] / ldiskfs / configure.ac
index 6ccf1c8..7adc144 100644 (file)
@@ -3,6 +3,9 @@
 AC_INIT([Lustre ldiskfs], 3.0.0, [https://bugzilla.lustre.org/])
 AC_CONFIG_SRCDIR([lustre-ldiskfs.spec.in])
 
+# Don't look for install-sh, etc. in ..
+AC_CONFIG_AUX_DIR([.])
+
 AC_CANONICAL_SYSTEM
 
 AM_INIT_AUTOMAKE
@@ -12,7 +15,21 @@ AC_PROG_CC
 LB_CANONICAL_SYSTEM
 LB_INCLUDE_RULES
 LB_PROG_CC
-LB_PROG_LINUX
+
+AC_MSG_CHECKING([whether to build kernel modules])
+AC_ARG_ENABLE([modules],
+       AC_HELP_STRING([--disable-modules],
+                       [disable building of Lustre kernel modules]),
+       [],[
+               enable_modules='yes'
+       ])
+AC_MSG_RESULT([$enable_modules])
+
+if test x$enable_modules = xyes ; then
+       LB_PROG_LINUX
+       LB_LINUX_MODPOST
+fi
+
 LB_CONFIG_HEADERS
 
 # These allow Lustre Makefiles and autoMakefiles to be used unchanged.
@@ -55,6 +72,7 @@ case $LINUXRELEASE in
 2.6.12*) LDISKFS_SERIES="2.6.12-vanilla.series" ;;
 2.6.15*) LDISKFS_SERIES="2.6-fc5.series";;
 2.6.16*) LDISKFS_SERIES="2.6-sles10.series";;
+2.6.18-*el5*) LDISKFS_SERIES="2.6-rhel5.series";;
 2.6.18*) LDISKFS_SERIES="2.6.18-vanilla.series";;
 *) AC_MSG_WARN([Unknown kernel version $LINUXRELEASE, fix ldiskfs/configure.ac])
 esac