Whamcloud - gitweb
LU-73 RHEL6 support.
[fs/lustre-release.git] / ldiskfs / configure.ac
index 7de84cf..7757d01 100644 (file)
@@ -1,21 +1,35 @@
 # Process this file with autoconf to produce a configure script.
 
-AC_INIT([Lustre ldiskfs], 3.0.8, [https://bugzilla.lustre.org/])
+AC_INIT([Lustre ldiskfs], 3.3.0, [https://bugzilla.lustre.org/])
 AC_CONFIG_SRCDIR([lustre-ldiskfs.spec.in])
+ldiskfs_is_ext4=yes
 
 # Don't look for install-sh, etc. in ..
 AC_CONFIG_AUX_DIR([.])
 
 AC_CANONICAL_SYSTEM
 
-AM_INIT_AUTOMAKE
+AM_INIT_AUTOMAKE([1.9 tar-ustar])
 
 AC_PROG_CC
 
 LB_CANONICAL_SYSTEM
+
+LB_DOWNSTREAM_RELEASE
+
+LB_BUILDID
+
 LB_INCLUDE_RULES
 LB_PROG_CC
 
+AC_ARG_ENABLE([dist],
+       AC_HELP_STRING([--enable-dist],
+                       [only configure enough for make dist]),
+       [enable_dist='yes'],[enable_dist='no'])
+AC_MSG_RESULT([$enable_dist])
+if test x$enable_dist != xno; then
+       enable_modules='no'
+fi
 
 #
 # LC_TARGET_SUPPORTED
@@ -33,13 +47,6 @@ $2
 esac
 ])
 
-AC_DEFUN([LC_KERNEL_WITH_EXT4],
-[if test -f $LINUX/fs/ext4/ext4.h ; then
-$1
-else
-$2
-fi
-])
 
 AC_MSG_CHECKING([whether to build kernel modules])
 AC_ARG_ENABLE([modules],
@@ -90,25 +97,23 @@ AM_CONDITIONAL(USE_QUILT, test x$QUILT != xno)
 
 LB_DEFINE_LDISKFS_OPTIONS
 
-AC_MSG_CHECKING([whether to build ldisk base on ext4])
-AC_ARG_ENABLE([ext4],
-             AC_HELP_STRING([--disable-ext4],
-                            [disable building of ldiskfs base on ext4]),[],
-                            [LC_KERNEL_WITH_EXT4([enable_ext4='yes'],
-                            [enable_ext4='no'])])
-AC_MSG_RESULT([$enable_ext4])
+LB_HAVE_EXT4_ENABLED
 
 if test x$enable_ext4 = xyes ; then
-        BACKFS=ext4
+       AC_DEFINE(HAVE_EXT4_LDISKFS, 1, [ldiskfs based on ext4])
+       BACKFS=ext4
 else
-        BACKFS=ext3
+       BACKFS=ext3
 fi
+
 AC_SUBST(BACKFS)
 BACKFSU=${BACKFS/ext/EXT}
 AC_SUBST(BACKFSU) # We need a Upper string
 
 AM_CONDITIONAL(USE_EXT4, test x$enable_ext4 = xyes)
 
+if test x$enable_dist != xyes; then
+       # don't need to do this if only configuring for make dist
 AC_MSG_CHECKING([which ldiskfs series to use])
 case $LINUXRELEASE in
 2.6.5*) LDISKFS_SERIES="2.6-suse.series" ;;
@@ -130,10 +135,12 @@ case $LINUXRELEASE in
        fi
        ;;
 2.6.22*) LDISKFS_SERIES="2.6.22-vanilla.series";;
-2.6.27*) LDISKFS_SERIES="2.6.27-vanilla.series";;
+2.6.27*) LDISKFS_SERIES="2.6-sles11.series";;
+2.6.32*) LDISKFS_SERIES="2.6-rhel6.series";;
 *) AC_MSG_WARN([Unknown kernel version $LINUXRELEASE, fix ldiskfs/configure.ac])
 esac
 AC_MSG_RESULT([$LDISKFS_SERIES])
+fi
 AC_SUBST(LDISKFS_SERIES)
 
 AC_SUBST(ac_configure_args)
@@ -150,18 +157,6 @@ LB_CHECK_SYMBOL_EXPORT([__d_rehash],
                                  [__d_rehash is exported by the kernel])],
                                  [])
 
-LB_CHECK_SYMBOL_EXPORT([d_move_locked],
-                      [fs/dcache.c],
-                      [AC_DEFINE(HAVE_D_MOVE_LOCKED, 1,
-                                 [d_move_locked is exported by the kernel])],
-                                 [])
-
-LB_CHECK_SYMBOL_EXPORT([__d_move],
-                      [fs/dcache.c],
-                      [AC_DEFINE(HAVE___D_MOVE, 1,
-                                 [__d_move exported by the kernel])],
-                                 [])
-
 LB_CONFIG_FILES
 AC_CONFIG_FILES([ldiskfs/autoMakefile ldiskfs/Makefile])