Whamcloud - gitweb
Correctly set lsm size for open replay.
[fs/lustre-release.git] / ldiskfs / configure.ac
index 7de84cf..70a5d22 100644 (file)
@@ -1,6 +1,6 @@
 # Process this file with autoconf to produce a configure script.
 
-AC_INIT([Lustre ldiskfs], 3.0.8, [https://bugzilla.lustre.org/])
+AC_INIT([Lustre ldiskfs], 3.0.9, [https://bugzilla.lustre.org/])
 AC_CONFIG_SRCDIR([lustre-ldiskfs.spec.in])
 
 # Don't look for install-sh, etc. in ..
@@ -90,19 +90,29 @@ AM_CONDITIONAL(USE_QUILT, test x$QUILT != xno)
 
 LB_DEFINE_LDISKFS_OPTIONS
 
-AC_MSG_CHECKING([whether to build ldisk base on ext4])
-AC_ARG_ENABLE([ext4],
-             AC_HELP_STRING([--disable-ext4],
-                            [disable building of ldiskfs base on ext4]),[],
-                            [LC_KERNEL_WITH_EXT4([enable_ext4='yes'],
-                            [enable_ext4='no'])])
+AC_MSG_CHECKING([whether to build ldiskfs based on ext4])
+if test x$RHEL_KERNEL = xyes; then
+       AC_ARG_ENABLE([ext4],
+               AC_HELP_STRING([--enable-ext4],
+                            [enable building of ldiskfs based on ext4]),
+                            [], [enable_ext4='no'])
+else
+       case $LINUXRELEASE in
+       # ext4 was in 2.6.22-2.6.26 but not stable enough to use
+       2.6.2[0-6]*) enable_ext4='no' ;;
+       *) LC_KERNEL_WITH_EXT4([enable_ext4='yes'],
+                              [enable_ext4='no']) ;;
+       esac
+fi
 AC_MSG_RESULT([$enable_ext4])
 
 if test x$enable_ext4 = xyes ; then
-        BACKFS=ext4
+       AC_DEFINE(HAVE_EXT4_LDISKFS, 1, [ldiskfs based on ext4])
+       BACKFS=ext4
 else
-        BACKFS=ext3
+       BACKFS=ext3
 fi
+
 AC_SUBST(BACKFS)
 BACKFSU=${BACKFS/ext/EXT}
 AC_SUBST(BACKFSU) # We need a Upper string
@@ -130,7 +140,7 @@ case $LINUXRELEASE in
        fi
        ;;
 2.6.22*) LDISKFS_SERIES="2.6.22-vanilla.series";;
-2.6.27*) LDISKFS_SERIES="2.6.27-vanilla.series";;
+2.6.27*) LDISKFS_SERIES="2.6-sles11.series";;
 *) AC_MSG_WARN([Unknown kernel version $LINUXRELEASE, fix ldiskfs/configure.ac])
 esac
 AC_MSG_RESULT([$LDISKFS_SERIES])