Whamcloud - gitweb
LU-3200 mdc: layout lock rpc must not take rpc_lock
[fs/lustre-release.git] / ldiskfs / configure.ac
index 44b4983..4dd5f67 100644 (file)
@@ -1,7 +1,7 @@
 # Process this file with autoconf to produce a configure script.
 
 AC_PREREQ([2.57])
-AC_INIT([Lustre ldiskfs], 3.3.0, [http://bugs.whamcloud.com/])
+AC_INIT([Lustre ldiskfs], 4.1.0, [http://bugs.whamcloud.com/])
 AC_CONFIG_SRCDIR([lustre-ldiskfs.spec.in])
 
 # Don't look for install-sh, etc. in ..
@@ -12,6 +12,7 @@ AC_CONFIG_MACRO_DIR([config])
 AC_CANONICAL_SYSTEM
 
 AM_INIT_AUTOMAKE([1.10 tar-ustar -Wno-portability])
+AM_MAINTAINER_MODE([enable])
 
 AC_PROG_CC
 
@@ -46,11 +47,8 @@ if test x$enable_modules = xyes ; then
        ])
        LB_LINUX_CONFIG([MODVERSIONS])
        LB_LINUX_CONFIG([KALLSYMS],[],[
-               if test "x$ARCH_UM" = "x" ; then
-                       AC_MSG_ERROR([ldiskfs requires that CONFIG_KALLSYMS is enabled in your kernel.])
-               fi
+               AC_MSG_ERROR([ldiskfs requires that CONFIG_KALLSYMS is enabled in your kernel.])
        ])
-       LB_LINUX_MODPOST
 fi
 
 LB_LDISKFS_SERIES([test x$enable_dist = xno])
@@ -68,8 +66,6 @@ AC_ARG_ENABLE([server],
        ])
 AC_MSG_RESULT([$enable_server])
 
-LB_CONFIG_HEADERS
-
 LDISKFSDIR="$PWD/ldiskfs"
 AC_SUBST(LDISKFSDIR)
 
@@ -78,10 +74,11 @@ LDISKFS_AC_PATCH_PROGRAM
 if test x$enable_server$enable_dist = xyesno ; then
 LB_LDISKFS_EXT_DIR
 LB_LDISKFS_EXT_SOURCE
-LB_LDISKFS_DEFINE_OPTIONS
+LB_EXT_FREE_BLOCKS_WITH_BUFFER_HEAD
+LB_EXT_PBLOCK
 fi
 
-AM_CONDITIONAL(LDISKFS_PDO, test x$with_ldiskfs_pdo = xyes)
+LB_CONFIG_HEADERS
 
 AC_SUBST(ac_configure_args)