Whamcloud - gitweb
b=19674
[fs/lustre-release.git] / ldiskfs / configure.ac
index 7de84cf..1102b81 100644 (file)
@@ -1,6 +1,6 @@
 # Process this file with autoconf to produce a configure script.
 
-AC_INIT([Lustre ldiskfs], 3.0.8, [https://bugzilla.lustre.org/])
+AC_INIT([Lustre ldiskfs], 3.0.9, [https://bugzilla.lustre.org/])
 AC_CONFIG_SRCDIR([lustre-ldiskfs.spec.in])
 
 # Don't look for install-sh, etc. in ..
@@ -90,15 +90,24 @@ AM_CONDITIONAL(USE_QUILT, test x$QUILT != xno)
 
 LB_DEFINE_LDISKFS_OPTIONS
 
-AC_MSG_CHECKING([whether to build ldisk base on ext4])
+AC_MSG_CHECKING([whether to build ldisk based on ext4])
 AC_ARG_ENABLE([ext4],
              AC_HELP_STRING([--disable-ext4],
-                            [disable building of ldiskfs base on ext4]),[],
+                            [enable building of ldiskfs based on ext4]),[],
                             [LC_KERNEL_WITH_EXT4([enable_ext4='yes'],
                             [enable_ext4='no'])])
 AC_MSG_RESULT([$enable_ext4])
 
+# Remove this part when RHEL5 ext4 patches landed.
+case $LINUXRELEASE in
+2.6.18*) if test x$RHEL_KENEL = xyes; then
+        enable_ext4=no
+        fi
+;;
+esac
+
 if test x$enable_ext4 = xyes ; then
+        AC_DEFINE(HAVE_EXT4_LDISKFS, 1, [ldiskfs based on ext4])
         BACKFS=ext4
 else
         BACKFS=ext3
@@ -130,7 +139,7 @@ case $LINUXRELEASE in
        fi
        ;;
 2.6.22*) LDISKFS_SERIES="2.6.22-vanilla.series";;
-2.6.27*) LDISKFS_SERIES="2.6.27-vanilla.series";;
+2.6.27*) LDISKFS_SERIES="2.6-sles11.series";;
 *) AC_MSG_WARN([Unknown kernel version $LINUXRELEASE, fix ldiskfs/configure.ac])
 esac
 AC_MSG_RESULT([$LDISKFS_SERIES])