Whamcloud - gitweb
LU-1812 fsfilt: ext4_free_blocks() has changed slightly
[fs/lustre-release.git] / ldiskfs / configure.ac
index 1d838df..0ef1c1d 100644 (file)
@@ -12,6 +12,7 @@ AC_CONFIG_MACRO_DIR([config])
 AC_CANONICAL_SYSTEM
 
 AM_INIT_AUTOMAKE([1.10 tar-ustar -Wno-portability])
+AM_MAINTAINER_MODE([enable])
 
 AC_PROG_CC
 
@@ -46,11 +47,8 @@ if test x$enable_modules = xyes ; then
        ])
        LB_LINUX_CONFIG([MODVERSIONS])
        LB_LINUX_CONFIG([KALLSYMS],[],[
-               if test "x$ARCH_UM" = "x" ; then
-                       AC_MSG_ERROR([ldiskfs requires that CONFIG_KALLSYMS is enabled in your kernel.])
-               fi
+               AC_MSG_ERROR([ldiskfs requires that CONFIG_KALLSYMS is enabled in your kernel.])
        ])
-       LB_LINUX_MODPOST
 fi
 
 LB_LDISKFS_SERIES([test x$enable_dist = xno])
@@ -68,8 +66,6 @@ AC_ARG_ENABLE([server],
        ])
 AC_MSG_RESULT([$enable_server])
 
-LB_CONFIG_HEADERS
-
 LDISKFSDIR="$PWD/ldiskfs"
 AC_SUBST(LDISKFSDIR)
 
@@ -78,9 +74,11 @@ LDISKFS_AC_PATCH_PROGRAM
 if test x$enable_server$enable_dist = xyesno ; then
 LB_LDISKFS_EXT_DIR
 LB_LDISKFS_EXT_SOURCE
-LB_LDISKFS_DEFINE_OPTIONS
+LB_EXT_FREE_BLOCKS_WITH_BUFFER_HEAD
 fi
 
+LB_CONFIG_HEADERS
+
 AC_SUBST(ac_configure_args)
 
 AC_CONFIG_FILES([Makefile ldiskfs/Makefile]