Whamcloud - gitweb
LU-3012 ubuntu: fix client module build
[fs/lustre-release.git] / debian / rules
index 39dcbe9..d504f87 100755 (executable)
@@ -75,6 +75,11 @@ MODS_PKG=lustre-client-modules
 BUILDDIR=.
 SRCDIR=.
 
+AVAIL_CPUS := $(shell getconf _NPROCESSORS_ONLN 2>/dev/null || echo 1)
+ifneq ($(AVAIL_CPUS),1)
+      PMAKEARGS := -j $(AVAIL_CPUS)
+endif
+
 autogen: autogen-stamp
 autogen-stamp: patch-stamp
        # see if any patches requires us to run autogen
@@ -84,8 +89,13 @@ autogen-stamp: patch-stamp
        #  needed autogen.sh scripts
        #  see https://bugzilla.lustre.org/attachment.cgi?id=27156
        #  for an example)
-       if grep "^--- .*\/autoconf" debian/patches/*; then \
-               if [ ! -f autogen.sh ]; then \
+       if grep -e "^--- .*\/autoconf\/" \
+               -e "^--- .*\/autoMakefile\.am" \
+               -e "^--- .*\/Makefile\.am" \
+               -e "^--- .*\/configure\.ac" \
+               -e "^--- .*\/configure\.in" \
+           debian/patches/*; then \
+               if [ ! -f build/autogen.sh ]; then \
                        echo "You have patches which require autogen.sh to be run, but it doesn't exist"; \
                        echo "Please see https://bugzilla.lustre.org/attachment.cgi?id=27156"; \
                        exit 1; \
@@ -96,7 +106,7 @@ autogen-stamp: patch-stamp
                cp /usr/share/misc/config.guess config.guess; \
                cp /usr/share/misc/config.guess libsysio/config.guess; \
                cp /usr/share/misc/config.guess ldiskfs/config.guess; \
-               sh ./autogen.sh; \
+               sh build/autogen.sh; \
        fi; \
        touch $@
 
@@ -125,7 +135,7 @@ build-arch build-indep: build
 build: build-stamp
 build-stamp: patch-stamp configure-stamp
        dh_testdir
-       $(MAKE) -C $(BUILDDIR)
+       $(MAKE) -C $(BUILDDIR) $(PMAKEARGS)
        $(MAKE) -C $(BUILDDIR) DESTDIR=$(TOP_DIR)/debian/tmp install
        # jump our lustre-client-modules into the control file if not using m-a
        if ! $(USE_MA); then \
@@ -351,6 +361,7 @@ kdist_config: prep-deb-files patch-stamp
        find . -type f -print0 | xargs -0 touch -r COPYING \;
        # Doesn't seem possible to only build modules...
        ./configure --with-linux=$(KSRC) \
+                   --disable-server \
                    --disable-quilt  \
                    --disable-dependency-tracking \
                    --disable-doc  \
@@ -370,7 +381,7 @@ kdist_configure: kdist_config
 binary-modules: prep-deb-files
        dh_testroot
        dh_clean -k
-       $(MAKE)
+       $(MAKE) $(PMAKEARGS)
        $(MAKE) install DESTDIR=$(CURDIR)/debian/$(PKGNAME)
        # Remove stuff that doesn't belong (no module-only target)
        cd $(CURDIR)/debian/$(PKGNAME) && rm -rf usr sbin etc
@@ -388,7 +399,7 @@ binary-modules: prep-deb-files
 clean:
        dh_testdir
        dh_testroot
-       dpatch deapply-all
+       dpatch deapply-all -v
        -$(MAKE) distclean
        rm -rf  debian/substvars debian/*.bak debian/*~ *~  *-stamp debian/$(PATCH_PKG)
        ls -d debian/lustre-client-modules-* | grep -v _KVERS_ | xargs rm -f || true
@@ -403,11 +414,11 @@ clean:
 
 patch: patch-stamp
 patch-stamp:
-       dpatch apply-all
+       dpatch apply-all -v
        touch $@
 
 unpatch:
-       dpatch deapply-all
+       dpatch deapply-all -v
        rm -rf debian/patched patch-stamp
 
 .PHONY: binary-arch clean source diff  binary binary-indep binary-arch install configure