Whamcloud - gitweb
LU-3012 ubuntu: fix client module build
[fs/lustre-release.git] / debian / rules
index 0a80989..d504f87 100755 (executable)
@@ -89,7 +89,12 @@ autogen-stamp: patch-stamp
        #  needed autogen.sh scripts
        #  see https://bugzilla.lustre.org/attachment.cgi?id=27156
        #  for an example)
-       if grep -e "^--- .*\/autoconf" -e ".*\/configure\.ac" -e ".*\/configure\.in" debian/patches/*; then \
+       if grep -e "^--- .*\/autoconf\/" \
+               -e "^--- .*\/autoMakefile\.am" \
+               -e "^--- .*\/Makefile\.am" \
+               -e "^--- .*\/configure\.ac" \
+               -e "^--- .*\/configure\.in" \
+           debian/patches/*; then \
                if [ ! -f build/autogen.sh ]; then \
                        echo "You have patches which require autogen.sh to be run, but it doesn't exist"; \
                        echo "Please see https://bugzilla.lustre.org/attachment.cgi?id=27156"; \
@@ -356,6 +361,7 @@ kdist_config: prep-deb-files patch-stamp
        find . -type f -print0 | xargs -0 touch -r COPYING \;
        # Doesn't seem possible to only build modules...
        ./configure --with-linux=$(KSRC) \
+                   --disable-server \
                    --disable-quilt  \
                    --disable-dependency-tracking \
                    --disable-doc  \