Whamcloud - gitweb
LU-13455 ptlrpc: connect to MDT stucks
[fs/lustre-release.git] / debian / rules
index c7546af..cbb4a5b 100755 (executable)
@@ -63,7 +63,7 @@ UPVERSION=$(shell echo $(VERSION) | sed -e 's/-[^-]*$$//')
 KVER?=$(LINUXRELEASE)
 
 # KVERS, KSRC are the kernel version and source to use when building lustre
-# Will be the default when building lustre-utils, etc but whatever module-assistant
+# Will be the default when building lustre-{server,client}-utils, etc but whatever module-assistant
 # supplied when building modules
 KVERS?=$(KVER)
 KSRC?=$(LINUX_OBJ)
@@ -186,11 +186,19 @@ configure-stamp: autogen-stamp debian/control.main debian/control.modules.in
        else \
                export EXTRAFLAGS="$${EXTRAFLAGS} --disable-ldiskfs"; \
        fi; \
+       if echo "$${DEB_BUILD_PROFILES}" | grep -q "o2ib"; then \
+               export EXTRAFLAGS="$${EXTRAFLAGS} --with-o2ib=$${O2IB_SRC}"; \
+       fi; \
        if echo "$${DEB_BUILD_PROFILES}" | grep -qw "gss"; then \
                export EXTRAFLAGS="$${EXTRAFLAGS} --enable-gss"; \
        elif echo "$${DEB_BUILD_PROFILES}" | grep -qw "nogss"; then \
                export EXTRAFLAGS="$${EXTRAFLAGS} --disable-gss"; \
        fi; \
+       if echo "$${DEB_BUILD_PROFILES}" | grep -qw "crypto"; then \
+               export EXTRAFLAGS="$${EXTRAFLAGS} --enable-crypto"; \
+       elif echo "$${DEB_BUILD_PROFILES}" | grep -qw "nocrypto"; then \
+               export EXTRAFLAGS="$${EXTRAFLAGS} --disable-crypto"; \
+       fi; \
        echo "Final value of EXTRAFLAGS: $${EXTRAFLAGS}"; \
        ( cd $(BUILDDIR) && \
                $(SRCDIR)/configure --disable-dependency-tracking \
@@ -199,6 +207,7 @@ configure-stamp: autogen-stamp debian/control.main debian/control.modules.in
                        --disable-snmp \
                        --enable-quota \
                        $${EXTRAFLAGS} \
+                       $(EXTRA_OPTIONS) \
        ); \
        touch $@
 
@@ -468,6 +477,14 @@ kdist_config: prep-deb-files patch-stamp
                export EXTRAFLAGS="$${EXTRAFLAGS} \
                        --disable-ldiskfs --disable-quilt"; \
        fi; \
+       if echo "$${DEB_BUILD_PROFILES}" | grep -q "o2ib"; then \
+               export EXTRAFLAGS="$${EXTRAFLAGS} --with-o2ib=$${O2IB_SRC}"; \
+       fi; \
+       if echo "$${DEB_BUILD_PROFILES}" | grep -qw "crypto"; then \
+               export EXTRAFLAGS="$${EXTRAFLAGS} --enable-crypto"; \
+       elif echo "$${DEB_BUILD_PROFILES}" | grep -qw "nocrypto"; then \
+               export EXTRAFLAGS="$${EXTRAFLAGS} --disable-crypto"; \
+       fi; \
        echo "Final value of EXTRAFLAGS: $${EXTRAFLAGS}"; \
        ./configure --with-linux=$(KSRC_TREE) \
                --with-linux-obj=$(KSRC) \
@@ -477,7 +494,7 @@ kdist_config: prep-deb-files patch-stamp
                --disable-snmp \
                --disable-tests \
                --enable-quota \
-               --with-kmp-moddir=updates \
+               --with-kmp-moddir=updates/kernel \
                $${EXTRAFLAGS} \
                $(EXTRA_OPTIONS)