Whamcloud - gitweb
LU-7304 ldiskfs: fix bug when bigalloc is enabled
[fs/lustre-release.git] / debian / rules
index 9c257f3..7fe36a2 100755 (executable)
@@ -28,8 +28,8 @@ endif
 #CC?=gcc-3.3
 #export CC
 
-# This is the debhelper compatability version to use.
-export DH_COMPAT=5
+# This is the debhelper compatibility version to use.
+export DH_COMPAT=7
 
 # Module-assistant stuff
 PACKAGE=lustre-client-modules
@@ -40,23 +40,21 @@ MA_DIR ?= /usr/share/modass
 ARCH=$(shell dpkg --print-architecture)
 TOP_DIR:=$(shell pwd)
 
-#  the lustre build process. This is $(KERNEL_VERSION)
+# This is the Lustre version
 VERSION=$(shell sed -n -e '1s/.*(\(.*\)) .*/\1/p' debian/changelog)
-#SUPPORTED_KERNELS=2.6.27
-SUPPORTED_KERNELS=2.6.18 2.6.20 2.6.22
 UPVERSION=$(shell echo $VERSION | sed -e 's/-[^-]*$$//')
-#KERNEL_VERSION=2.6.27
-# the kernel version to build all of this with
-#KVER=2.6.27-11-generic
-# if the above is not set, default to whatever kernel is booted
-KVER?=$$(uname -r)
-KERNEL_TREE=/lib/modules/$(KVER)/build
+
+# KVER is set to LINUXRELEASE being by autoconf which is either
+# $(uname -r) or the version of the source specified by the user
+KVER?=$(LINUXRELEASE)
+
 # KVERS, KSRC are the kernel version and source to use when building lustre
 # Will be the default when building lustre-utils, etc but whatever module-assistant
 # supplied when building modules
-KVERS?=$(KERNEL_VERSION)
-#KSRC?=$(KERNEL_TREE)
-KSRC=$(KERNEL_TREE)
+KVERS?=$(KVER)
+KSRC?=$(LINUX_OBJ)
+KSRC_TREE?=$(LINUX)
+IB_OPTIONS?=""
 
 # Packages
 PATCH_PKG=linux-patch-lustre
@@ -100,10 +98,8 @@ autogen-stamp: patch-stamp
                        exit 1; \
                fi; \
                cp /usr/share/misc/config.sub config.sub; \
-               cp /usr/share/misc/config.sub libsysio/config.sub; \
                cp /usr/share/misc/config.sub ldiskfs/config.sub; \
                cp /usr/share/misc/config.guess config.guess; \
-               cp /usr/share/misc/config.guess libsysio/config.guess; \
                cp /usr/share/misc/config.guess ldiskfs/config.guess; \
                sh build/autogen.sh; \
        fi; \
@@ -115,10 +111,9 @@ configure-stamp: autogen-stamp debian/control.main debian/control.modules.in
        # touch files to same date, to avoid auto*
        find . -type f -print0 | xargs -0 touch -r COPYING; \
        if [ "$(BUILDDIR)" != "." ]; then \
-               mkdir -p $(BUILDDIR)/build $(BUILDDIR)/lustre/contrib $(BUILDDIR)/libsysio; \
+               mkdir -p $(BUILDDIR)/build $(BUILDDIR)/lustre/contrib; \
                cp build/Makefile $(BUILDDIR)/build/; \
                cp lustre/contrib/mpich-*.patch $(BUILDDIR)/lustre/contrib/; \
-               ln -s ../../../libsysio/include $(BUILDDIR)/libsysio/; \
        fi
        ( cd $(BUILDDIR) && \
         $(SRCDIR)/configure --disable-dependency-tracking \
@@ -340,17 +335,18 @@ kdist_config: prep-deb-files patch-stamp
        # touch files to same date, to avoid auto*
        find . -type f -print0 | xargs -0 touch -r COPYING \;
        # Doesn't seem possible to only build modules...
-       ./configure --with-linux=$(KSRC) \
+       ./configure --with-linux=$(KSRC_TREE) \
+                   --with-linux-obj=$(KSRC) \
                    --disable-server \
                    --disable-quilt  \
                    --disable-dependency-tracking \
                    --disable-doc  \
                    --disable-utils \
-                   --disable-liblustre \
+                   --disable-iokit \
                    --disable-snmp \
-                   --disable-zerocopy \
                    --disable-tests \
-                   --enable-quota
+                   --enable-quota \
+                   $(IB_OPTIONS)
 
 kdist_configure: kdist_config
 
@@ -359,7 +355,7 @@ kdist_configure: kdist_config
 # during a normal build
 binary-modules: prep-deb-files
        dh_testroot
-       dh_clean -k
+       dh_prep
        $(MAKE) $(PMAKEARGS)
        $(MAKE) install DESTDIR=$(CURDIR)/debian/$(PKGNAME)
        # Remove stuff that doesn't belong (no module-only target)
@@ -373,7 +369,7 @@ binary-modules: prep-deb-files
        dh_gencontrol -- -v$(VERSION)
        dh_md5sums -p $(PKGNAME)
        dh_builddeb --destdir=$(DEB_DESTDIR) -p $(PKGNAME)
-       dh_clean -k -p $(PKGNAME)
+       dh_prep -p $(PKGNAME)
 
 clean:
        dh_testdir