Whamcloud - gitweb
LU-9550 adio: delete the old Lustre ADIO driver patches
[fs/lustre-release.git] / debian / rules
index bef0c49..70cc1d8 100755 (executable)
@@ -28,7 +28,7 @@ endif
 #CC?=gcc-3.3
 #export CC
 
-# This is the debhelper compatability version to use.
+# This is the debhelper compatibility version to use.
 export DH_COMPAT=7
 
 # Module-assistant stuff
@@ -54,6 +54,7 @@ KVER?=$(LINUXRELEASE)
 KVERS?=$(KVER)
 KSRC?=$(LINUX_OBJ)
 KSRC_TREE?=$(LINUX)
+IB_OPTIONS?=""
 
 # Packages
 PATCH_PKG=linux-patch-lustre
@@ -112,7 +113,6 @@ configure-stamp: autogen-stamp debian/control.main debian/control.modules.in
        if [ "$(BUILDDIR)" != "." ]; then \
                mkdir -p $(BUILDDIR)/build $(BUILDDIR)/lustre/contrib; \
                cp build/Makefile $(BUILDDIR)/build/; \
-               cp lustre/contrib/mpich-*.patch $(BUILDDIR)/lustre/contrib/; \
        fi
        ( cd $(BUILDDIR) && \
         $(SRCDIR)/configure --disable-dependency-tracking \
@@ -344,7 +344,9 @@ kdist_config: prep-deb-files patch-stamp
                    --disable-iokit \
                    --disable-snmp \
                    --disable-tests \
-                   --enable-quota
+                   --enable-quota \
+                   --with-kmp-moddir=updates \
+                   $(IB_OPTIONS)
 
 kdist_configure: kdist_config