Whamcloud - gitweb
LU-1199 build: Simplify autotools version checks
[fs/lustre-release.git] / debian / rules
index 06ef5af..5e59622 100755 (executable)
@@ -89,7 +89,12 @@ autogen-stamp: patch-stamp
        #  needed autogen.sh scripts
        #  see https://bugzilla.lustre.org/attachment.cgi?id=27156
        #  for an example)
-       if grep -e "^--- .*\/autoconf" -e ".*\/configure\.ac" -e ".*\/configure\.in" debian/patches/*; then \
+       if grep -e "^--- .*\/autoconf\/" \
+               -e "^--- .*\/autoMakefile\.am" \
+               -e "^--- .*\/Makefile\.am" \
+               -e "^--- .*\/configure\.ac" \
+               -e "^--- .*\/configure\.in" \
+           debian/patches/*; then \
                if [ ! -f build/autogen.sh ]; then \
                        echo "You have patches which require autogen.sh to be run, but it doesn't exist"; \
                        echo "Please see https://bugzilla.lustre.org/attachment.cgi?id=27156"; \
@@ -393,7 +398,7 @@ binary-modules: prep-deb-files
 clean:
        dh_testdir
        dh_testroot
-       dpatch deapply-all
+       dpatch deapply-all -v
        -$(MAKE) distclean
        rm -rf  debian/substvars debian/*.bak debian/*~ *~  *-stamp debian/$(PATCH_PKG)
        ls -d debian/lustre-client-modules-* | grep -v _KVERS_ | xargs rm -f || true
@@ -408,11 +413,11 @@ clean:
 
 patch: patch-stamp
 patch-stamp:
-       dpatch apply-all
+       dpatch apply-all -v
        touch $@
 
 unpatch:
-       dpatch deapply-all
+       dpatch deapply-all -v
        rm -rf debian/patched patch-stamp
 
 .PHONY: binary-arch clean source diff  binary binary-indep binary-arch install configure