Whamcloud - gitweb
LU-12539 build: pass --with-o2ib when building deb packages
[fs/lustre-release.git] / debian / rules
index d7b0ea3..33f7878 100755 (executable)
@@ -63,7 +63,7 @@ UPVERSION=$(shell echo $(VERSION) | sed -e 's/-[^-]*$$//')
 KVER?=$(LINUXRELEASE)
 
 # KVERS, KSRC are the kernel version and source to use when building lustre
-# Will be the default when building lustre-utils, etc but whatever module-assistant
+# Will be the default when building lustre-{server,client}-utils, etc but whatever module-assistant
 # supplied when building modules
 KVERS?=$(KVER)
 KSRC?=$(LINUX_OBJ)
@@ -158,8 +158,22 @@ configure-stamp: autogen-stamp debian/control.main debian/control.modules.in
        echo "Enabled Build Profiles: $${DEB_BUILD_PROFILES}"
        if echo "$${DEB_BUILD_PROFILES}" | grep -q "server"; then \
                export EXTRAFLAGS="--enable-server"; \
+               if echo "$${DEB_BUILD_PROFILES}" | grep -q "systemd"; then \
+                       cp debian/lustre-server-utils.install.in \
+                               debian/lustre-server-utils.install; \
+               else \
+                       sed /systemd/d debian/lustre-server-utils.install.in \
+                               > debian/lustre-server-utils.install; \
+               fi; \
        else \
                export EXTRAFLAGS="--disable-server"; \
+               if echo "$${DEB_BUILD_PROFILES}" | grep -q "systemd"; then \
+                       cp debian/lustre-client-utils.install.in \
+                               debian/lustre-client-utils.install; \
+               else \
+                       sed /systemd/d debian/lustre-client-utils.install.in \
+                               > debian/lustre-client-utils.install; \
+               fi; \
        fi; \
        if echo "$${DEB_BUILD_PROFILES}" | grep -q "zfs"; then \
                export EXTRAFLAGS="$${EXTRAFLAGS} --with-zfs=$${ZFS_SRC} --with-spl=$${SPL_SRC}"; \
@@ -172,6 +186,9 @@ configure-stamp: autogen-stamp debian/control.main debian/control.modules.in
        else \
                export EXTRAFLAGS="$${EXTRAFLAGS} --disable-ldiskfs"; \
        fi; \
+       if echo "$${DEB_BUILD_PROFILES}" | grep -q "o2ib"; then \
+               export EXTRAFLAGS="$${EXTRAFLAGS} --with-o2ib=$${O2IB_SRC}"; \
+       fi; \
        if echo "$${DEB_BUILD_PROFILES}" | grep -qw "gss"; then \
                export EXTRAFLAGS="$${EXTRAFLAGS} --enable-gss"; \
        elif echo "$${DEB_BUILD_PROFILES}" | grep -qw "nogss"; then \
@@ -185,6 +202,7 @@ configure-stamp: autogen-stamp debian/control.main debian/control.modules.in
                        --disable-snmp \
                        --enable-quota \
                        $${EXTRAFLAGS} \
+                       $(EXTRA_OPTIONS) \
        ); \
        touch $@
 
@@ -454,6 +472,9 @@ kdist_config: prep-deb-files patch-stamp
                export EXTRAFLAGS="$${EXTRAFLAGS} \
                        --disable-ldiskfs --disable-quilt"; \
        fi; \
+       if echo "$${DEB_BUILD_PROFILES}" | grep -q "o2ib"; then \
+               export EXTRAFLAGS="$${EXTRAFLAGS} --with-o2ib=$${O2IB_SRC}"; \
+       fi; \
        echo "Final value of EXTRAFLAGS: $${EXTRAFLAGS}"; \
        ./configure --with-linux=$(KSRC_TREE) \
                --with-linux-obj=$(KSRC) \
@@ -463,7 +484,7 @@ kdist_config: prep-deb-files patch-stamp
                --disable-snmp \
                --disable-tests \
                --enable-quota \
-               --with-kmp-moddir=updates \
+               --with-kmp-moddir=updates/kernel \
                $${EXTRAFLAGS} \
                $(EXTRA_OPTIONS)