Whamcloud - gitweb
LU-12539 build: pass --with-o2ib when building deb packages
[fs/lustre-release.git] / debian / rules
index 3c2bdbe..33f7878 100755 (executable)
@@ -186,6 +186,9 @@ configure-stamp: autogen-stamp debian/control.main debian/control.modules.in
        else \
                export EXTRAFLAGS="$${EXTRAFLAGS} --disable-ldiskfs"; \
        fi; \
+       if echo "$${DEB_BUILD_PROFILES}" | grep -q "o2ib"; then \
+               export EXTRAFLAGS="$${EXTRAFLAGS} --with-o2ib=$${O2IB_SRC}"; \
+       fi; \
        if echo "$${DEB_BUILD_PROFILES}" | grep -qw "gss"; then \
                export EXTRAFLAGS="$${EXTRAFLAGS} --enable-gss"; \
        elif echo "$${DEB_BUILD_PROFILES}" | grep -qw "nogss"; then \
@@ -469,6 +472,9 @@ kdist_config: prep-deb-files patch-stamp
                export EXTRAFLAGS="$${EXTRAFLAGS} \
                        --disable-ldiskfs --disable-quilt"; \
        fi; \
+       if echo "$${DEB_BUILD_PROFILES}" | grep -q "o2ib"; then \
+               export EXTRAFLAGS="$${EXTRAFLAGS} --with-o2ib=$${O2IB_SRC}"; \
+       fi; \
        echo "Final value of EXTRAFLAGS: $${EXTRAFLAGS}"; \
        ./configure --with-linux=$(KSRC_TREE) \
                --with-linux-obj=$(KSRC) \