Whamcloud - gitweb
LU-5093 test: dir_remote.sh change stripe count
[fs/lustre-release.git] / configure.ac
index ce1df2a..b772a0f 100644 (file)
@@ -1,45 +1,24 @@
-sinclude(lustre/version.m4)
+AC_PREREQ([2.57])
+AC_INIT([Lustre], [LUSTRE_VERSION], [http://bugs.whamcloud.com/], [lustre])
+sinclude(lustre/autoconf/lustre-version.ac)
 
-AC_INIT([Lustre], [LUSTRE_VERSION], [http://bugzilla.lustre.org/], [lustre])
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_MACRO_DIR([config])
 
-if test "LUSTRE_VERSION" = "LUSTRE""_VERSION" ; then
-       cat >&2 <<-EOF
-       This script was not built with a version number.
+LB_CHECK_VERSION
 
-       This is likely due to an incorrect checkout, or a broken
-       tarball.
+LC_CONFIG_SRCDIR
 
-       Please see README.lustrecvs, or contact your Lustre vendor.
-       EOF
-       exit 1
-fi
+AC_CANONICAL_SYSTEM
 
-AC_CONFIG_SRCDIR(lustre/obdclass/obdo.c)
-AM_INIT_AUTOMAKE
-# AM_MAINTAINER_MODE
+AM_INIT_AUTOMAKE([1.10 tar-ustar -Wno-portability])
+AM_MAINTAINER_MODE([enable])
 
-sinclude(build/build.ac)
-sinclude(portals/portals.ac)
-sinclude(lustre/lustre.ac)
+AC_PROG_CC
+AC_PROG_LIBTOOL
 
-AC_CONFIG_HEADERS([config.h])
+AM_PROG_AS
 
-CPPFLAGS="-include \$(top_builddir)/config.h $CPPFLAGS"
-EXTRA_KCFLAGS="-include $PWD/config.h $EXTRA_KCFLAGS"
-AC_SUBST(EXTRA_KCFLAGS)
+AC_CHECK_TOOLS(AR, ar)
 
-AC_OUTPUT([
-Makefile
-autoMakefile
-])
-
-cat <<EOF
-
-CPPFLAGS: $CPPFLAGS
-LLCPPFLAGS: $LLCPPFLAGS
-CFLAGS: $CFLAGS
-EXTRA_KCFLAGS: $EXTRA_KCFLAGS
-LLCFLAGS: $LLCFLAGS
-
-Type 'make' to build Lustre.
-EOF
+LB_CONFIGURE