Whamcloud - gitweb
LU-2675 liblustre: disable liblustre by default
[fs/lustre-release.git] / configure.ac
index 102257d..3876d62 100644 (file)
@@ -1,9 +1,9 @@
-
-AC_INIT([Lustre], [LUSTRE_VERSION], [https://bugzilla.lustre.org/], [lustre])
+AC_PREREQ([2.57])
+AC_INIT([Lustre], [LUSTRE_VERSION], [http://bugs.whamcloud.com/], [lustre])
 sinclude(lustre/autoconf/lustre-version.ac)
 
-# Overridden in LB_PATH_LDISKFS on certain branches
-AM_CONDITIONAL(LDISKFS_ENABLED, false)
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_MACRO_DIR([config])
 
 LB_CHECK_VERSION
 
@@ -11,9 +11,13 @@ LC_CONFIG_SRCDIR
 
 AC_CANONICAL_SYSTEM
 
-AM_INIT_AUTOMAKE
-# AM_MAINTAINER_MODE
+AM_INIT_AUTOMAKE([1.10 tar-ustar -Wno-portability])
+AM_MAINTAINER_MODE([enable])
 
 AC_PROG_CC
 
+AM_PROG_AS
+
+AC_CHECK_TOOLS(AR, ar)
+
 LB_CONFIGURE