Whamcloud - gitweb
596ea14c1bfcda64ab97657250a00eade5bacac9
[fs/lustre-release.git] / lustre / autoconf / lustre-version.ac
1 m4_define([LUSTRE_MAJOR],[2])
2 m4_define([LUSTRE_MINOR],[4])
3 m4_define([LUSTRE_PATCH],[92])
4 m4_define([LUSTRE_FIX],[0])
5
6 dnl # liblustre delta is 0.0.1.32 , next version with fixes is ok, but
7 dnl # after following release candidate/beta would spill this warning already.
8 m4_define([LUSTRE_VER_ALLOWED_OFFSET],["OBD_OCD_VERSION(0, 0, 1, 32)"])
9 m4_define([LUSTRE_LIB_VER_OFFSET_WARN],["OBD_OCD_VERSION(0, 0, 1, 32)"])
10
11 dnl # linux lustre delta is 0.4.0.0 , next stable release version is ok
12 m4_define([LUSTRE_CLI_VER_OFFSET_WARN],["OBD_OCD_VERSION(0, 4, 0, 0)"])
13
14 dnl # User editable part ends here. -----------------------------------------
15
16 m4_pattern_allow(AC_LUSTRE)
17 m4_define([LUSTRE_VERSION],m4_if(LUSTRE_FIX,[0],LUSTRE_MAJOR.LUSTRE_MINOR.LUSTRE_PATCH,LUSTRE_MAJOR.LUSTRE_MINOR.LUSTRE_PATCH.LUSTRE_FIX))
18
19 [AC_LUSTRE_MAJOR]=LUSTRE_MAJOR
20 [AC_LUSTRE_MINOR]=LUSTRE_MINOR
21 [AC_LUSTRE_PATCH]=LUSTRE_PATCH
22 [AC_LUSTRE_FIX]=LUSTRE_FIX
23 [AC_LUSTRE_VERSION_STRING]=LUSTRE_VERSION
24 [AC_LUSTRE_VER_ALLOWED_OFFSET]=LUSTRE_VER_ALLOWED_OFFSET
25 [AC_LUSTRE_LIB_VER_OFFSET_WARN]=LUSTRE_LIB_VER_OFFSET_WARN
26 [AC_LUSTRE_CLI_VER_OFFSET_WARN]=LUSTRE_CLI_VER_OFFSET_WARN
27
28 AC_SUBST([AC_LUSTRE_MAJOR])
29 AC_SUBST([AC_LUSTRE_MINOR])
30 AC_SUBST([AC_LUSTRE_PATCH])
31 AC_SUBST([AC_LUSTRE_FIX])
32 AC_SUBST([AC_LUSTRE_VERSION_STRING])
33 AC_SUBST([AC_LUSTRE_VER_ALLOWED_OFFSET])
34 AC_SUBST([AC_LUSTRE_LIB_VER_OFFSET_WARN])
35 AC_SUBST([AC_LUSTRE_CLI_VER_OFFSET_WARN])