Whamcloud - gitweb
LU-5761 tests: fix test_89 to use fs_log_size()
[fs/lustre-release.git] / lustre-dkms.spec.in
1 %bcond_without servers
2 %bcond_without zfs
3 %bcond_with ldiskfs
4
5 # Set the package name prefix
6 %if %{with servers}
7     %if %{with zfs}
8         %if %{with ldiskfs}
9             %define module @PACKAGE@-all
10         %else
11             %define module @PACKAGE@-zfs
12         %endif
13     %else
14         %if %{without ldiskfs}
15             %define module @PACKAGE@-BADSTATE
16         %else
17             %define module @PACKAGE@-ldiskfs
18         %endif
19     %endif
20     %define lustre_name @PACKAGE@
21
22 %else
23     %define module @PACKAGE@-client
24     %define lustre_name @PACKAGE@-client
25 %endif
26
27 %if %{_vendor}=="redhat" || %{_vendor}=="fedora"
28         %global kmod_name kmod-%{lustre_name}
29         %define mkconf_options
30 %else   #for Suse / Ubuntu
31         %global kmod_name %{lustre_name}-kmp
32         %define mkconf_options "-k updates"
33 %endif
34
35 %define buildid 1
36 %define mkconf  lustre/scripts/dkms.mkconf
37
38 # There should be a better (non-arch dependent) way to require ext4
39 # sources
40 %define ext4_source_rpm kernel-debuginfo-common-x86_64
41
42 Name:           %{module}-dkms
43
44 Version:        @VERSION@
45 Release:        %{buildid}%{?dist}
46 Summary:        Kernel module(s) (dkms)
47
48 Group:          System Environment/Kernel
49 License:        GPLv2+
50 URL:            http://lustre.opensfs.org/
51 Source0:        @PACKAGE@-%{version}.tar.gz
52 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
53 BuildArch:      noarch
54
55 # DKMS >= 2.2.0.3-28.git.7c3e7c5 to fully support inter-modules deps
56 # (ie, "BUILD_DEPENDS[#]=<pkg>"), and have latest DKMS fixes integrated
57 # for bugs that prevented our module to build/install.
58 Requires:       dkms >= 2.2.0.3-28.git.7c3e7c5
59 # for lnetctl
60 Requires:       libyaml-devel
61 %if %{with servers}
62 # If client package is installed when installing server, remove it since
63 # the server package also includes the client.  This can be removed if/when
64 # the packages are split into independent client/server/common packages.
65 Obsoletes:      @PACKAGE@-client < %{version}
66 %if %{with zfs}
67 Requires:       spl-dkms >= 0.6.5
68 Requires:       zfs-dkms >= 0.6.5
69 Requires:       @PACKAGE@-osd-zfs-mount
70 Conflicts:      @PACKAGE@-ldiskfs-dkms
71 Conflicts:      @PACKAGE@-client-dkms
72 # lustre-zfs-dkms replicates the functionality old lustre-dkms package
73 Provides:       @PACKAGE@-dkms
74 Obsoletes:      @PACKAGE@-dkms
75 %endif
76 %if %{with ldiskfs}
77 Requires:       %{ext4_source_rpm}
78 Requires:       @PACKAGE@-osd-ldiskfs-mount
79 Conflicts:      @PACKAGE@-zfs-dkms
80 Conflicts:      @PACKAGE@-client-dkms
81 %if "%{module}" != "@PACKAGE@-all"
82 Conflicts:      @PACKAGE@-dkms
83 %endif
84 %endif
85 %if "%{module}" != "@PACKAGE@-all"
86 Conflicts:      @PACKAGE@-all-dkms
87 %endif
88 %endif
89 Requires:       gcc, make, perl
90 Requires:       kernel-devel
91 Provides:       %{kmod_name} = %{version}
92 Provides:       @PACKAGE@-modules = %{version}
93 %if %{with servers}
94 %if %{with zfs}
95 Provides:       @PACKAGE@-osd-zfs = %{version}
96 %endif
97 %if %{with ldiskfs}
98 Provides:       @PACKAGE@-osd-ldiskfs = %{version}
99 %endif
100 Provides:       @PACKAGE@-osd
101 %else
102 Provides:       @PACKAGE@-client
103 %endif
104
105 %description
106 This package contains the dkms Lustre kernel modules.
107 %if %{with ldiskfs}
108
109 The required %{ext4_source_rpm} package is available from
110 the repository with other debuginfo rpms.
111 %endif
112
113 %prep
114 %setup -q -n @PACKAGE@-%{version}
115
116 %build
117 %{mkconf} -n %{module} -v %{version} -f dkms.conf %{mkconf_options}
118
119 %install
120 if [ "$RPM_BUILD_ROOT" != "/" ]; then
121     rm -rf $RPM_BUILD_ROOT
122 fi
123 mkdir -p $RPM_BUILD_ROOT/usr/src/
124 cp -rfp ${RPM_BUILD_DIR}/@PACKAGE@-%{version} $RPM_BUILD_ROOT/usr/src/
125 mv $RPM_BUILD_ROOT/usr/src/@PACKAGE@-%{version} $RPM_BUILD_ROOT/usr/src/%{module}-%{version}
126
127 %clean
128 if [ "$RPM_BUILD_ROOT" != "/" ]; then
129     rm -rf $RPM_BUILD_ROOT
130 fi
131
132 %files
133 %defattr(-,root,root)
134 /usr/src/%{module}-%{version}
135
136 %post
137 for POSTINST in /usr/lib/dkms/common.postinst; do
138     if [ -f $POSTINST ]; then
139         $POSTINST %{module} %{version}
140         exit $?
141     fi
142     echo "WARNING: $POSTINST does not exist."
143 done
144 echo -e "ERROR: DKMS version is too old and %{module} was not"
145 echo -e "built with legacy DKMS support."
146 echo -e "You must either rebuild %{module} with legacy postinst"
147 echo -e "support or upgrade DKMS to a more current version."
148 exit 1
149
150 %preun
151 dkms remove -m %{module} -v %{version} --all --rpm_safe_upgrade
152 exit 0
153
154 %changelog
155 * Mon Aug  1 2016 Nathaniel Clark <nathaniel.l.clark@intel.com>
156 - Add option to build either ldiskfs or zfs flavour of server version
157 * Sat Jan 23 2016 Bruno Faccini <bruno.faccini@intel.com>
158  - detect and handle cases where [spl,zfs]-dkms packages are not built
159  - also handle on-target configure issues
160 * Wed Oct  7 2015 Bruno Faccini <bruno.faccini@intel.com>
161  - adapted for Lustre Client DKMS creation
162  - allow for on-target reconfig to prevent static deps requires
163 * Mon Apr  8 2013 Brian Behlendorf <behlendorf1@llnl.gov> - 2.3.63-1
164 - First DKMS packages.