Whamcloud - gitweb
LU-3584 osd-zfs: error check dmu_tx_hold_sa
[fs/lustre-release.git] / contrib / lbuild / lbuild-sles11
1 # vim:expandtab:shiftwidth=4:softtabstop=4:tabstop=4:
2
3 # increment this if you have made a change that should force a new kernel
4 # to build built for this distribution (only -- if you want to force a kernel
5 # build on all distributions, update the BUILD_GEN variable in build/lbuild)
6 BUILD_GEN+=".0"
7
8 # This distro does not support zfs, so define ZFSNOTSUPPORTED
9 # use words that make the bash log readable.
10 ZFSNOTSUPPORTED="Zfs Not Supported"
11
12 source ${LBUILD_DIR}/lbuild-sles
13
14 edit_specs() {
15
16     # edit the SPECs with our changes
17     local spec
18     (cd $TOPDIR/SOURCES; ./mkspec --release ${lnxrel})
19     for spec in $RPMSMPTYPE source; do
20         #cp $TOPDIR/SOURCES/kernel-$spec.spec{,.orig}
21         sed -i -e "s/^\(Release: *\).*$/\1${lnxrel}_${buildid}/" \
22                -e '/^%setup /a\
23 cp  %_sourcedir/linux-3.0-lustre.patch %_builddir/%{name}-%{version}/lustre.patch\
24 ! grep -q lustre.patch %_sourcedir/series.conf && echo -e "\\n\\tlustre.patch" >> %_sourcedir/series.conf' \
25           SOURCES/kernel-${spec}.spec || \
26             fatal 1 "Error while editing SOURCES/kernel-${spec}.spec"
27
28         if $KERNEL_LUSTRE_NAMING; then
29             # these are all of the changes needed because we change the package names
30             # to kernel-lustre-*.  these should all go away when we stop this insanity
31             sed -i -e 's/^\(Name:.*kernel-\)\(.*\)/\1lustre-\2/' \
32                    -e "/^Provides:  *kernel = /a\
33 Provides:       kernel-$spec = %{version}-%{release}
34 " \
35                    -e 's/^\([   ][      ]*-i %_builddir\/kernel-\)\(source-2.6.27.21\/\$patch; then\)/\1lustre-\2/' \
36                    -e '/^%build/,/^%changelog/s/\(kernel-\)\(source\.files\)/\1lustre-\2/g' \
37                    -e '/--no-backup-if-mismatch/,/fi/s/kernel-source-/kernel-lustre-source-/g' \
38                    -e "s/^\(%package -n kernel-\)\(.*\)/\1lustre-\2/" \
39                    -e "s/^\(%description -n kernel-\)\(.*\)/\1lustre-\2/" \
40                    -e "s/^\(%files -n kernel-\)\(.*\)/\1lustre-\2/" \
41                    -e "s/^\(Provides:.*kernel-\)\(.*\)/\1lustre-\2/" \
42                    -e "s/^\(Requires:.*kernel-\)\(.*\)/\1lustre-\2/" \
43                    -e "s/^\(Supplements:.*kernel-\)\(.*\)/\1lustre-\2/" \
44                 SOURCES/kernel-${spec}.spec || \
45                 fatal 1 "Error while editing SOURCES/kernel-${spec}.spec"
46         fi
47
48         # XXX - a building-on-Ubuntu hack
49         if grep -q "Ubuntu" /etc/issue; then
50             sed -i -e '/^%_sourcedir\/install-configs %_sourcedir .*/i\
51 curl ftp://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.17/2.6.17-mm1/broken-out/i386-use-c-code-for-current_thread_info.patch | patch -p1' \
52                    -e 's/^\(BuildRequires: .*\)$/#NOU \1/g' \
53                    -e 's/%(\(chmod .*\))$/%(bash -c "\1")/' \
54                    -e 's/ -a 109//' \
55               SOURCES/kernel-${spec}.spec || \
56             fatal 1 "Error while editing SOURCES/kernel-${spec}.spec"
57         fi
58     done
59 }
60
61 unpack_linux_devel_rpm-sles11() {
62     local callers_rpm="$1"
63
64     local rpmdir="${callers_rpm%/*}"
65
66     local kernelrpm
67     local wanted_kernel="${lnxmaj}${lnxmin}-${lnxrel}"
68
69     # this is a hack that should go away when the modified lustre kernel
70     # Provides kernel-default-base                        vvvvvvvvv
71     if ! kernelrpm=$(find_rpm "$rpmdir" provides "^kernel-(lustre-)?default-base = $wanted_kernel"); then
72         fatal 1 "Could not find the kernel-default-base in $rpmdir/"
73     fi
74
75     if ! rpm2cpio < "$rpmdir/$kernelrpm" | cpio -id > /dev/null 2>&1; then
76         fatal 1 "Unpack error for $kernelrpm"
77     fi
78
79     if ! kernelrpm=$(find_rpm "$rpmdir" provides "^kernel-(lustre-)?default-devel = $wanted_kernel"); then
80         fatal 1 "Could not find the kernel-default-devel in $rpmdir/"
81     fi
82
83     if ! rpm2cpio < "$rpmdir/$kernelrpm" | cpio -id > /dev/null 2>&1; then
84         fatal 1 "Unpack error for $kernelrpm"
85     fi
86
87 }
88
89 find_linux_rpm-sles11() {
90     local prefix="$1"
91     local wanted_kernel="$2"
92     local pathtorpms=${3:-"${KERNELRPMSBASE}/${lnxmaj}/${DISTRO}/${TARGET_ARCH}"}
93
94     # what, oh what, do we do for sles11?
95     # if anyone knows how we get an arbitrary (kernel-source and
96     # kernel-default-base in this case) from the Suse update mechanism,
97     # please feel free to fix this
98
99     fatal 1 "I don't know how to get packages for SLES11"
100
101     return 0
102
103 }