Whamcloud - gitweb
LU-11742 test: have libtool execute the test binaries
[fs/lustre-release.git] / debian / rules
index 216d766..dbae257 100755 (executable)
@@ -63,7 +63,7 @@ UPVERSION=$(shell echo $(VERSION) | sed -e 's/-[^-]*$$//')
 KVER?=$(LINUXRELEASE)
 
 # KVERS, KSRC are the kernel version and source to use when building lustre
-# Will be the default when building lustre-utils, etc but whatever module-assistant
+# Will be the default when building lustre-{server,client}-utils, etc but whatever module-assistant
 # supplied when building modules
 KVERS?=$(KVER)
 KSRC?=$(LINUX_OBJ)
@@ -142,7 +142,7 @@ autogen-stamp: patch-stamp
 # modules, whereas the modules build omits the utilities, to create two
 # neatly separated debian files.
 #
-# Note: KERNEL_SRC, KERNEL_CFG, ZFS_SRC and SPL_SRC need to be set from the
+# Note: KERNEL_SRC, KERNEL_OBJ, ZFS_SRC and SPL_SRC need to be set from the
 # outside. This is done by "make debs". As such, invoking "debuild" or such
 # direct debian build tools will lead to a client-only build.
 configure: configure-stamp
@@ -181,10 +181,11 @@ configure-stamp: autogen-stamp debian/control.main debian/control.modules.in
        ( cd $(BUILDDIR) && \
                $(SRCDIR)/configure --disable-dependency-tracking \
                        --with-linux=$${KERNEL_SRC} \
-                       --with-linux-config=$${KERNEL_CFG} \
+                       --with-linux-obj=$${KERNEL_OBJ} \
                        --disable-snmp \
                        --enable-quota \
                        $${EXTRAFLAGS} \
+                       $(EXTRA_OPTIONS) \
        ); \
        touch $@