Whamcloud - gitweb
LU-17065 build: Remove snmp support
[fs/lustre-release.git] / debian / rules
index f3065dc..1aabf7e 100755 (executable)
@@ -1,12 +1,21 @@
 #!/usr/bin/make -f
+# SPDX-License-Identifier: NOASSERTION
+
 #
-# Created 2009 by Brian J. Murrell based on work by
-# Alastair McKinstry, <alastair.mckinstry@ichec.ie>, <mckinstry@debian.org>
-# Patrick Winnertz, and the pkg-lustre Debian maintainers
+# This file is part of Lustre, http://www.lustre.org/
+#
+# debian/rules
+#
+# Debian rules file
 #
 # Copying and modification is unlimited, provided that the modified
 # version is marked as being modified.
 # (This version has been modified from the original)
+#
+# Created 2009 by Brian J. Murrell based on work by
+# Alastair McKinstry, <alastair.mckinstry@ichec.ie>, <mckinstry@debian.org>
+# Patrick Winnertz, and the pkg-lustre Debian maintainers
+#
 
 # Uncomment this to turn on verbose mode.
 # export DH_VERBOSE=1
@@ -34,11 +43,6 @@ else
         CFLAGS += -O2
 endif
 
-# We need the kernels to be built with gcc-3.3; suspect that gcc-4.1 uses too
-# much stack and crashes because of it.
-#CC?=gcc-3.3
-#export CC
-
 # This is the debhelper compatibility version to use.
 export DH_COMPAT=11
 
@@ -215,7 +219,6 @@ configure-stamp: autogen-stamp debian/control.main debian/control.modules.in
                $(SRCDIR)/configure --disable-dependency-tracking \
                        --with-linux=$${KERNEL_SRC} \
                        --with-linux-obj=$${KERNEL_OBJ} \
-                       --disable-snmp \
                        --enable-quota \
                        $${EXTRAFLAGS} \
                        $(EXTRA_OPTIONS) \
@@ -262,7 +265,6 @@ binary-$(UTILS_PKG): build-stamp
        rm -rf debian/$(UTILS_PKG)/usr/bin/iokit-* \
               debian/$(UTILS_PKG)/usr/bin/*-survey \
               debian/$(UTILS_PKG)/usr/bin/mcreate \
-              debian/$(UTILS_PKG)/usr/bin/munlink \
               debian/$(UTILS_PKG)/usr/bin/statx \
               debian/$(UTILS_PKG)/usr/sbin/wirecheck \
               debian/$(UTILS_PKG)/usr/sbin/wiretest
@@ -519,10 +521,9 @@ kdist_config: prep-deb-files patch-stamp
                --disable-dependency-tracking \
                --disable-doc  \
                --disable-iokit \
-               --disable-snmp \
                --disable-tests \
                --enable-quota \
-               --with-kmp-moddir=updates \
+               --with-kmp-moddir=updates/kernel \
                $${EXTRAFLAGS} \
                $(EXTRA_OPTIONS)